CVE-2024-2044
Fixed in a distro release EPSS 79%CVSS 9.9
pgAdmin <= 8.3 is affected by a path-traversal vulnerability while deserializing users’ sessions in the session handling code. If the server is running on Windows, an unauthenticated attacker can load and deserialize remote pickle objects and gain code execution. If the server is running on POSIX/Linux, an authenticated attacker can upload pickle objects, deserialize them, and gain code execution.
Products: pgadmin.org pgAdmin 4, postgresql pgadmin_4, fedoraproject fedora
Fixed upstream
| Ecosystem | Package | Fixed in |
|---|---|---|
| PyPI | pgadmin4 | 8.4 |
Distro releases
| Release | Package | Fixed in |
|---|---|---|
| SUSE Enterprise Storage 7.1 | pgadmin4 | 4.30-150300.3.12.1 |
| SUSE Linux Enterprise High Performance Computing 15 SP3-LTSS | pgadmin4 | 4.30-150300.3.12.1 |
| SUSE Linux Enterprise High Performance Computing 15 SP4-ESPOS | pgadmin4 | 4.30-150300.3.12.1 |
| SUSE Linux Enterprise High Performance Computing 15 SP4-LTSS | pgadmin4 | 4.30-150300.3.12.1 |
| SUSE Linux Enterprise Module for Server Applications 15 SP5 | pgadmin4 | 4.30-150300.3.12.1 |
| SUSE Linux Enterprise Server 15 SP3-LTSS | pgadmin4 | 4.30-150300.3.12.1 |
| SUSE Linux Enterprise Server 15 SP4-LTSS | pgadmin4 | 4.30-150300.3.12.1 |
| SUSE Linux Enterprise Server for SAP Applications 15 SP3 | pgadmin4 | 4.30-150300.3.12.1 |
| SUSE Linux Enterprise Server for SAP Applications 15 SP4 | pgadmin4 | 4.30-150300.3.12.1 |
| SUSE Manager Proxy 4.3 | pgadmin4 | 4.30-150300.3.12.1 |
| SUSE Manager Server 4.3 | pgadmin4 | 4.30-150300.3.12.1 |
| openSUSE Leap 15.5 | pgadmin4 | 4.30-150300.3.12.1 |
| openSUSE Tumbleweed | pgadmin4 | 8.5-1.1 |