CVE-2024-1329
Fixed upstream EPSS <1%CVSS 7.7
HashiCorp Nomad and Nomad Enterprise 1.5.13 up to 1.6.6, and 1.7.3 template renderer is vulnerable to arbitrary file write on the host as the Nomad client user through symlink attacks. This vulnerability, CVE-2024-1329, is fixed in Nomad 1.7.4, 1.6.7, and 1.5.14.
Products: HashiCorp Nomad, HashiCorp Nomad Enterprise
Fixed upstream
| Ecosystem | Package | Fixed in |
|---|---|---|
| Go | github.com/hashicorp/nomad | 1.5.14 |
| Go | github.com/hashicorp/nomad | 1.6.7 |
| Go | github.com/hashicorp/nomad | 1.7.4 |
Distro releases
| Release | Package | Fixed in |
|---|---|---|
| Ubuntu 18.04 LTS | nomad | no fix |
| Ubuntu 20.04 LTS | nomad | no fix |