CVE-2023-6936
Fixed in a distro release EPSS <1%CVSS 5.3
In wolfSSL prior to 5.6.6, if callback functions are enabled (via the WOLFSSL_CALLBACKS flag), then a malicious TLS client or network attacker can trigger a buffer over-read on the heap of 5 bytes (WOLFSSL_CALLBACKS is only intended for debugging).
Products: wolfssl
Distro releases
| Release | Package | Fixed in |
|---|---|---|
| Debian 12 | wolfssl | no fix |
| Debian 13 | wolfssl | 5.6.6-1.2 |
| Ubuntu 16.04 LTS | wolfssl | no fix |
| Ubuntu 18.04 LTS | wolfssl | no fix |
| Ubuntu 20.04 LTS | wolfssl | no fix |
| Ubuntu 22.04 LTS | wolfssl | no fix |