CVE-2023-50290
Fixed upstream EPSS 68%CVSS 6.5
Exposure of Sensitive Information to an Unauthorized Actor vulnerability in Apache Solr. The Solr Metrics API publishes all unprotected environment variables available to each Apache Solr instance. Users are able to specify which environment variables to hide, however, the default list is designed to work for known secret Java system properties. Environment variables cannot be strictly defined in Solr, like Java system properties can be, and may be set for the entire host, unlike Java system properties which are set per-Java-proccess. The Solr Metrics API is protected by the "metrics-read" permission. Therefore, Solr Clouds with Authorization setup will only be vulnerable via users with the "metrics-read" permission. This issue affects Apache Solr: from 9.0.0 before 9.3.0. Users are recommended to upgrade to version 9.3.0 or later, in which environment variables are not published via the Metrics API.
Products: Apache Software Foundation Apache Solr
Fixed upstream
| Ecosystem | Package | Fixed in |
|---|---|---|
| Maven | org.apache.solr:solr-core | 9.3.0 |
Distro releases
| Release | Package | Fixed in |
|---|---|---|
| Ubuntu 20.04 LTS | lucene-solr | no fix |
| Ubuntu 22.04 LTS | lucene-solr | no fix |
| Ubuntu 24.04 LTS | lucene-solr | no fix |
| Ubuntu 25.10 | lucene-solr | no fix |
| Ubuntu 26.04 LTS | lucene-solr | no fix |
| Ubuntu 26.10 | lucene-solr | no fix |
| Ubuntu Pro 14.04 LTS | lucene-solr | no fix |
| Ubuntu Pro 16.04 LTS | lucene-solr | no fix |
| Ubuntu Pro 18.04 LTS | lucene-solr | no fix |