Patchwire CVEs, their patch status, and feeds to follow them

CVE-2023-49920

Fixed upstream EPSS 1%

Apache Airflow, version 2.7.0 through 2.7.3, has a vulnerability that allows an attacker to trigger a DAG in a GET request without CSRF validation. As a result, it was possible for a malicious website opened in the same browser - by the user who also had Airflow UI opened - to trigger the execution of DAGs without the user's consent. Users are advised to upgrade to version 2.8.0 or later which is not affected

Published 2023-12-21 · CVE record · OSV

Products: Apache Software Foundation Apache Airflow

Fixed upstream

EcosystemPackageFixed in
PyPIapache-airflow2.8.0
PyPIapache-airflow2.8.0b1