Patchwire CVEs, their patch status, and feeds to follow them

CVE-2023-49145

Fixed upstream EPSS 1%CVSS 7.9

Apache NiFi 0.7.0 through 1.23.2 include the JoltTransformJSON Processor, which provides an advanced configuration user interface that is vulnerable to DOM-based cross-site scripting. If an authenticated user, who is authorized to configure a JoltTransformJSON Processor, visits a crafted URL, then arbitrary JavaScript code can be executed within the session context of the authenticated user. Upgrading to Apache NiFi 1.24.0 or 2.0.0-M1 is the recommended mitigation.

Published 2023-11-27 · CVE record · OSV

Products: Apache Software Foundation Apache NiFi

Fixed upstream

EcosystemPackageFixed in
Mavenorg.apache.nifi:nifi-jolt-transform-json-ui1.24.0