CVE-2023-49086
Fixed in a distro release EPSS 1%CVSS 5.4
Cacti is a robust performance and fault management framework and a frontend to RRDTool - a Time Series Database (TSDB). A vulnerability in versions prior to 1.2.27 bypasses an earlier fix for CVE-2023-39360, therefore leading to a DOM XSS attack. Exploitation of the vulnerability is possible for an authorized user. The vulnerable component is the `graphs_new.php`. The impact of the vulnerability is execution of arbitrary JavaScript code in the attacked user's browser. This issue has been patched in version 1.2.27.
Products: cacti
Distro releases
| Release | Package | Fixed in |
|---|---|---|
| Debian 10 | cacti | 1.2.2+ds1-2+deb10u6 |
| Debian 11 | cacti | 1.2.16+ds1-2+deb11u3 |
| Debian 12 | cacti | 1.2.24+ds1-1+deb12u2 |
| Debian 13 | cacti | 1.2.26+ds1-1 |
| Debian 14 | cacti | 1.2.26+ds1-1 |
| SUSE Package Hub 12 | cacti | 1.2.26-bp155.2.6.1 |
| SUSE Package Hub 12 | cacti-spine | 1.2.26-bp155.2.6.1 |
| SUSE Package Hub 15 SP5 | cacti | 1.2.26-bp155.2.6.1 |
| SUSE Package Hub 15 SP5 | cacti-spine | 1.2.26-bp155.2.6.1 |
| Ubuntu Pro 14.04 LTS | cacti | no fix |
| Ubuntu Pro 16.04 LTS | cacti | no fix |
| Ubuntu Pro 18.04 LTS | cacti | no fix |
| Ubuntu Pro 20.04 LTS | cacti | no fix |
| Ubuntu Pro 22.04 LTS | cacti | no fix |
| openSUSE Leap 15.5 | cacti | 1.2.26-bp155.2.6.1 |
| openSUSE Leap 15.5 | cacti-spine | 1.2.26-bp155.2.6.1 |
| openSUSE Tumbleweed | cacti | 1.2.26-1.1 |