CVE-2023-46749
Fixed in a distro release EPSS 1%CVSS 6.5
Apache Shiro before 1.13.0 or 2.0.0-alpha-4, may be susceptible to a path traversal attack that results in an authentication bypass when used together with path rewriting Mitigation: Update to Apache Shiro 1.13.0+ or 2.0.0-alpha-4+, or ensure `blockSemicolon` is enabled (this is the default).
Products: Apache Software Foundation Apache Shiro
Fixed upstream
| Ecosystem | Package | Fixed in |
|---|---|---|
| Maven | org.apache.shiro:shiro-core | 1.13.0 |
| Maven | org.apache.shiro:shiro-core | 2.0.0-alpha4 |
Distro releases
| Release | Package | Fixed in |
|---|---|---|
| Debian 12 | shiro | 1.3.2-5 |
| Debian 13 | shiro | 1.3.2-5 |
| Debian 14 | shiro | 1.3.2-5 |
| Ubuntu 20.04 LTS | shiro | no fix |
| Ubuntu 22.04 LTS | shiro | no fix |
| Ubuntu Pro 16.04 LTS | shiro | no fix |
| Ubuntu Pro 16.04 LTS | shiro | 1.2.4-1ubuntu0.1~esm2 |
| Ubuntu Pro 18.04 LTS | shiro | no fix |
| Ubuntu Pro 24.04 LTS | shiro | 1.3.2-5ubuntu0.24.04.1~esm1 |