CVE-2023-46734
Fixed in a distro release EPSS <1%CVSS 6.1
Symfony is a PHP framework for web and console applications and a set of reusable PHP components. Starting in versions 2.0.0, 5.0.0, and 6.0.0 and prior to versions 4.4.51, 5.4.31, and 6.3.8, some Twig filters in CodeExtension use `is_safe=html` but don't actually ensure their input is safe. As of versions 4.4.51, 5.4.31, and 6.3.8, Symfony now escapes the output of the affected filters.
Products: symfony
Fixed upstream
| Ecosystem | Package | Fixed in |
|---|---|---|
| Packagist | symfony/symfony | 4.4.51 |
| Packagist | symfony/symfony | 5.4.31 |
| Packagist | symfony/symfony | 6.3.8 |
| Packagist | symfony/twig-bridge | 4.4.51 |
| Packagist | symfony/twig-bridge | 5.4.31 |
| Packagist | symfony/twig-bridge | 6.3.8 |
Distro releases
| Release | Package | Fixed in |
|---|---|---|
| Debian 10 | symfony | 3.4.22+dfsg-2+deb10u3 |
| Debian 12 | symfony | 5.4.23+dfsg-1+deb12u1 |
| Debian 13 | symfony | 5.4.31+dfsg-1 |
| Debian 14 | symfony | 5.4.31+dfsg-1 |
| Ubuntu 16.04 LTS | symfony | no fix |
| Ubuntu Pro 18.04 LTS | symfony | no fix |
| Ubuntu Pro 20.04 LTS | symfony | 4.3.8+dfsg-1ubuntu1+esm2 |
| Ubuntu Pro 22.04 LTS | symfony | 5.4.4+dfsg-1ubuntu8+esm1 |
| Ubuntu Pro 24.04 LTS | symfony | 6.4.5+dfsg-3ubuntu3+esm1 |