CVE-2023-39362
Fixed in a distro release EPSS 85%CVSS 7.2
Cacti is an open source operational monitoring and fault management framework. In Cacti 1.2.24, under certain conditions, an authenticated privileged user, can use a malicious string in the SNMP options of a Device, performing command injection and obtaining remote code execution on the underlying server. The `lib/snmp.php` file has a set of functions, with similar behavior, that accept in input some variables and place them into an `exec` call without a proper escape or validation. This issue has been addressed in version 1.2.25. Users are advised to upgrade. There are no known workarounds for this vulnerability.
Products: cacti
Distro releases
| Release | Package | Fixed in |
|---|---|---|
| Debian 10 | cacti | 1.2.2+ds1-2+deb10u6 |
| Debian 11 | cacti | 1.2.16+ds1-2+deb11u2 |
| Debian 12 | cacti | 1.2.24+ds1-1+deb12u1 |
| Debian 13 | cacti | 1.2.25+ds1-1 |
| Debian 14 | cacti | 1.2.25+ds1-1 |
| SUSE Package Hub 12 | cacti | 1.2.25-bp155.2.3.1 |
| SUSE Package Hub 12 | cacti-spine | 1.2.25-bp155.2.3.1 |
| SUSE Package Hub 15 SP4 | cacti | 1.2.25-bp155.2.3.1 |
| SUSE Package Hub 15 SP4 | cacti-spine | 1.2.25-bp155.2.3.1 |
| SUSE Package Hub 15 SP5 | cacti | 1.2.25-bp155.2.3.1 |
| SUSE Package Hub 15 SP5 | cacti-spine | 1.2.25-bp155.2.3.1 |
| Ubuntu 24.04 LTS | cacti | no fix |
| Ubuntu Pro 14.04 LTS | cacti | no fix |
| Ubuntu Pro 16.04 LTS | cacti | no fix |
| Ubuntu Pro 18.04 LTS | cacti | no fix |
| Ubuntu Pro 20.04 LTS | cacti | no fix |
| Ubuntu Pro 22.04 LTS | cacti | no fix |
| openSUSE Leap 15.4 | cacti | 1.2.25-bp155.2.3.1 |
| openSUSE Leap 15.4 | cacti-spine | 1.2.25-bp155.2.3.1 |
| openSUSE Leap 15.5 | cacti | 1.2.25-bp155.2.3.1 |
| openSUSE Leap 15.5 | cacti-spine | 1.2.25-bp155.2.3.1 |
| openSUSE Tumbleweed | cacti | 1.2.25-2.1 |