CVE-2023-38522
Fixed in a distro release EPSS <1%CVSS 7.5
Apache Traffic Server accepts characters that are not allowed for HTTP field names and forwards malformed requests to origin servers. This can be utilized for request smuggling and may also lead cache poisoning if the origin servers are vulnerable. This issue affects Apache Traffic Server: from 8.0.0 through 8.1.10, from 9.0.0 through 9.2.4. Users are recommended to upgrade to version 8.1.11 or 9.2.5, which fixes the issue.
Products: Apache Software Foundation Apache Traffic Server, apache traffic_server
Distro releases
| Release | Package | Fixed in |
|---|---|---|
| Debian 11 | trafficserver | 8.1.11+ds-0+deb11u1 |
| Debian 12 | trafficserver | 9.2.5+ds-0+deb12u1 |
| Ubuntu 16.04 LTS | trafficserver | no fix |
| Ubuntu 18.04 LTS | trafficserver | no fix |
| Ubuntu 24.04 LTS | trafficserver | no fix |
| Ubuntu Pro 20.04 LTS | trafficserver | no fix |
| Ubuntu Pro 22.04 LTS | trafficserver | no fix |