Patchwire CVEs, their patch status, and feeds to follow them

CVE-2023-37579

Fixed upstream EPSS <1%CVSS 8.2

Incorrect Authorization vulnerability in Apache Software Foundation Apache Pulsar Function Worker. This issue affects Apache Pulsar: before 2.10.4, and 2.11.0. Any authenticated user can retrieve a source's configuration or a sink's configuration without authorization. Many sources and sinks contain credentials in the configuration, which could lead to leaked credentials. This vulnerability is mitigated by the fact that there is not a known way for an authenticated user to enumerate another tenant's sources or sinks, meaning the source or sink name would need to be guessed in order to exploit this vulnerability. The recommended mitigation for impacted users is to upgrade the Pulsar Function Worker to a patched version. 2.10 Pulsar Function Worker users should upgrade to at least 2.10.4. 2.11 Pulsar Function Worker users should upgrade to at least 2.11.1. 3.0 Pulsar Function Worker users are unaffected. Any users running the Pulsar Function Worker for 2.9.* and earlier should upgrade to one of the above patched versions.

Published 2023-07-12 · CVE record · OSV

Products: Apache Software Foundation Apache Pulsar Function Worker, apache pulsar

Fixed upstream

EcosystemPackageFixed in
Mavenorg.apache.pulsar:pulsar-functions-worker2.10.4
Mavenorg.apache.pulsar:pulsar-functions-worker2.11.1