CVE-2023-34478
Fixed in a distro release EPSS 2%CVSS 9.8
Apache Shiro, before 1.12.0 or 2.0.0-alpha-3, may be susceptible to a path traversal attack that results in an authentication bypass when used together with APIs or other web frameworks that route requests based on non-normalized requests. Mitigation: Update to Apache Shiro 1.12.0+ or 2.0.0-alpha-3+
Products: Apache Software Foundation Apache Shiro, apache shiro
Fixed upstream
| Ecosystem | Package | Fixed in |
|---|---|---|
| Maven | org.apache.shiro:shiro-web | 1.12.0 |
| Maven | org.apache.shiro:shiro-web | 2.0.0-alpha-3 |
Distro releases
| Release | Package | Fixed in |
|---|---|---|
| Debian 12 | shiro | no fix |
| Debian 13 | shiro | no fix |
| Debian 14 | shiro | no fix |
| Ubuntu 20.04 LTS | shiro | no fix |
| Ubuntu 22.04 LTS | shiro | no fix |
| Ubuntu Pro 16.04 LTS | shiro | no fix |
| Ubuntu Pro 16.04 LTS | shiro | 1.2.4-1ubuntu0.1~esm2 |
| Ubuntu Pro 18.04 LTS | shiro | no fix |
| Ubuntu Pro 24.04 LTS | shiro | 1.3.2-5ubuntu0.24.04.1~esm1 |