CVE-2023-32314
Fixed upstream EPSS 8%CVSS 9.8
vm2 is a sandbox that can run untrusted code with Node's built-in modules. A sandbox escape vulnerability exists in vm2 for versions up to and including 3.9.17. It abuses an unexpected creation of a host object based on the specification of `Proxy`. As a result a threat actor can bypass the sandbox protections to gain remote code execution rights on the host running the sandbox. This vulnerability was patched in the release of version `3.9.18` of `vm2`. Users are advised to upgrade. There are no known workarounds for this vulnerability.
Products: patriksimek vm2
Fixed upstream
| Ecosystem | Package | Fixed in |
|---|---|---|
| npm | vm2 | 3.9.18 |