CVE-2023-32197
Fixed in a distro release EPSS <1%CVSS 6.6
A Improper Privilege Management vulnerability in SUSE rancher in RoleTemplateobjects when external=true is set can lead to privilege escalation in specific scenarios.This issue affects rancher: from 2.7.0 before 2.7.14, from 2.8.0 before 2.8.5.
Products: SUSE Rancher
Fixed upstream
| Ecosystem | Package | Fixed in |
|---|---|---|
| Go | github.com/rancher/rancher | 2.7.14 |
| Go | github.com/rancher/rancher | 2.8.5 |
| Go | github.com/rancher/rancher | 2.8.9 |
| Go | github.com/rancher/rancher | 2.9.3 |
| Go | github.com/rancher/rancher | no fix |
Distro releases
| Release | Package | Fixed in |
|---|---|---|
| Chainguard | harvester | 1.8.1-r1 |
| Chainguard | harvester-fips | 1.8.1-r0 |
| Chainguard | harvester-fips-webhook | 1.8.1-r0 |
| Chainguard | harvester-webhook | 1.8.1-r1 |
| SUSE Linux Enterprise Module for Package Hub 15 SP5 | govulncheck-vulndb | 0.0.20241030T212825-150000.1.9.1 |
| SUSE Linux Enterprise Module for Package Hub 15 SP6 | govulncheck-vulndb | 0.0.20241030T212825-150000.1.9.1 |
| SUSE Package Hub 12 | govulncheck-vulndb | 0.0.20241104T154416-5.1 |
| openSUSE Leap 15.5 | govulncheck-vulndb | 0.0.20241030T212825-150000.1.9.1 |
| openSUSE Leap 15.6 | govulncheck-vulndb | 0.0.20241030T212825-150000.1.9.1 |
| openSUSE Tumbleweed | govulncheck-vulndb | 0.0.20241030T212825-1.1 |