CVE-2023-30631
Fixed in a distro release EPSS 2%
Improper Input Validation vulnerability in Apache Software Foundation Apache Traffic Server. The configuration option proxy.config.http.push_method_enabled didn't function. However, by default the PUSH method is blocked in the ip_allow configuration file.This issue affects Apache Traffic Server: from 8.0.0 through 9.2.0. 8.x users should upgrade to 8.1.7 or later versions 9.x users should upgrade to 9.2.1 or later versions
Products: Apache Software Foundation Apache Traffic Server
Distro releases
| Release | Package | Fixed in |
|---|---|---|
| Debian 10 | trafficserver | 8.1.7-0+deb10u1 |
| Debian 11 | trafficserver | 8.1.7+ds-1~deb11u1 |
| Debian 12 | trafficserver | 9.2.0+ds-2+deb12u1 |
| Ubuntu 16.04 LTS | trafficserver | no fix |
| Ubuntu 18.04 LTS | trafficserver | no fix |
| Ubuntu Pro 20.04 LTS | trafficserver | no fix |
| Ubuntu Pro 22.04 LTS | trafficserver | no fix |