CVE-2023-30547
Fixed upstream EPSS 73%CVSS 9.8
vm2 is a sandbox that can run untrusted code with whitelisted Node's built-in modules. There exists a vulnerability in exception sanitization of vm2 for versions up to 3.9.16, allowing attackers to raise an unsanitized host exception inside `handleException()` which can be used to escape the sandbox and run arbitrary code in host context. This vulnerability was patched in the release of version `3.9.17` of `vm2`. There are no known workarounds for this vulnerability. Users are advised to upgrade.
Products: patriksimek vm2
Fixed upstream
| Ecosystem | Package | Fixed in |
|---|---|---|
| npm | vm2 | 3.9.17 |