CVE-2023-29159
Fixed in a distro release EPSS 2%CVSS 7.5
Directory traversal vulnerability in Starlette versions 0.13.5 and later and prior to 0.27.0 allows a remote unauthenticated attacker to view files in a web service which was built using Starlette.
Products: Encode Starlette
Fixed upstream
| Ecosystem | Package | Fixed in |
|---|---|---|
| PyPI | starlette | 0.27.0 |
Distro releases
| Release | Package | Fixed in |
|---|---|---|
| Debian 12 | starlette | 0.26.1-1+deb12u1 |
| Debian 13 | starlette | 0.28.0-1 |
| Debian 14 | starlette | 0.28.0-1 |
| Ubuntu 22.04 LTS | starlette | no fix |