CVE-2023-2798
Fixed upstream EPSS <1%CVSS 7.5
Those using HtmlUnit to browse untrusted webpages may be vulnerable to Denial of service attacks (DoS). If HtmlUnit is running on user supplied web pages, an attacker may supply content that causes HtmlUnit to crash by a stack overflow. This effect may support a denial of service attack.This issue affects htmlunit before 2.70.0.
Products: htmlunit
Fixed upstream
| Ecosystem | Package | Fixed in |
|---|---|---|
| Maven | org.htmlunit:htmlunit | 2.70.0 |
Distro releases
| Release | Package | Fixed in |
|---|---|---|
| Ubuntu 16.04 LTS | jenkins-htmlunit-core-js | no fix |
| Ubuntu 18.04 LTS | jenkins-htmlunit-core-js | no fix |
| Ubuntu 20.04 LTS | jenkins-htmlunit-core-js | no fix |
| Ubuntu Pro 16.04 LTS | htmlunit | no fix |
| Ubuntu Pro 18.04 LTS | htmlunit | no fix |