CVE-2023-2745
Fixed in a distro release EPSS 79%CVSS 5.4
WordPress Core is vulnerable to Directory Traversal in versions up to, and including, 6.2, via the ‘wp_lang’ parameter. This allows unauthenticated attackers to access and load arbitrary translation files. In cases where an attacker is able to upload a crafted translation file onto the site, such as via an upload form, this could be also used to perform a Cross-Site Scripting attack.
Products: WordPress Foundation WordPress
Distro releases
| Release | Package | Fixed in |
|---|---|---|
| Debian 10 | wordpress | 5.0.19+dfsg1-0+deb10u1 |
| Debian 11 | wordpress | 5.7.11+dfsg1-0+deb11u1 |
| Debian 12 | wordpress | 6.1.6+dfsg1-0+deb12u1 |
| Debian 13 | wordpress | 6.2.1+dfsg1-1 |
| Debian 14 | wordpress | 6.2.1+dfsg1-1 |
| Ubuntu 16.04 LTS | wordpress | no fix |
| Ubuntu 18.04 LTS | wordpress | no fix |
| Ubuntu 20.04 LTS | wordpress | no fix |
| Ubuntu 22.04 LTS | wordpress | no fix |
| Ubuntu 24.04 LTS | wordpress | no fix |