CVE-2023-26437
Fixed in a distro release EPSS <1%CVSS 3.4
Denial of service vulnerability in PowerDNS Recursor allows authoritative servers to be marked unavailable.This issue affects Recursor: through 4.6.5, through 4.7.4 , through 4.8.3.
Products: powerdns recursor
Distro releases
| Release | Package | Fixed in |
|---|---|---|
| Debian 12 | pdns-recursor | 4.8.4-1 |
| Debian 13 | pdns-recursor | 4.8.4-1 |
| Debian 14 | pdns-recursor | 4.8.4-1 |
| SUSE Package Hub 15 SP4 | pdns-recursor | 4.6.6-bp154.2.6.1 |
| SUSE Package Hub 15 SP5 | pdns-recursor | 4.8.6-bp155.2.3.1 |
| Ubuntu 24.04 LTS | pdns-recursor | no fix |
| Ubuntu 25.10 | pdns-recursor | no fix |
| Ubuntu 26.04 LTS | pdns-recursor | no fix |
| Ubuntu 26.10 | pdns-recursor | no fix |
| Ubuntu Pro 16.04 LTS | pdns-recursor | no fix |
| Ubuntu Pro 18.04 LTS | pdns-recursor | no fix |
| Ubuntu Pro 20.04 LTS | pdns-recursor | no fix |
| Ubuntu Pro 22.04 LTS | pdns-recursor | no fix |
| openSUSE Leap 15.4 | pdns-recursor | 4.6.6-bp154.2.6.1 |
| openSUSE Leap 15.5 | pdns-recursor | 4.8.6-bp155.2.3.1 |
| openSUSE Tumbleweed | pdns-recursor | 4.8.4-1.1 |