CVE-2023-26119
Fixed upstream EPSS 3%CVSS 9.8
Versions of the package net.sourceforge.htmlunit:htmlunit from 0 and before 3.0.0 are vulnerable to Remote Code Execution (RCE) via XSTL, when browsing the attacker’s webpage.
Products: htmlunit
Fixed upstream
| Ecosystem | Package | Fixed in |
|---|---|---|
| Maven | net.sourceforge.htmlunit:htmlunit | 3.0.0 |
Distro releases
| Release | Package | Fixed in |
|---|---|---|
| Chainguard | hadoop-fips-3.3.6 | no fix |
| Chainguard | hadoop-fips-3.4.2 | no fix |
| Chainguard | hadoop-fips-3.5 | no fix |