CVE-2023-20873
Fixed upstream EPSS 1%CVSS 9.8
In Spring Boot versions 3.0.0 - 3.0.5, 2.7.0 - 2.7.10, and older unsupported versions, an application that is deployed to Cloud Foundry could be susceptible to a security bypass. Users of affected versions should apply the following mitigation: 3.0.x users should upgrade to 3.0.6+. 2.7.x users should upgrade to 2.7.11+. Users of older, unsupported versions should upgrade to 3.0.6+ or 2.7.11+.
Products: vmware spring_boot
Fixed upstream
| Ecosystem | Package | Fixed in |
|---|---|---|
| Maven | org.springframework.boot:spring-boot-actuator-autoconfigure | 3.0.6 |
| Maven | org.springframework.boot:spring-boot-actuator-autoconfigure | 2.7.11 |
| Maven | org.springframework.boot:spring-boot-actuator-autoconfigure | 2.6.15 |
| Maven | org.springframework.boot:spring-boot-actuator-autoconfigure | 2.5.15 |