Patchwire CVEs, their patch status, and feeds to follow them

CVE-2023-0872

Fixed upstream EPSS 3%CVSS 8.2

The Horizon REST API includes a users endpoint in OpenMNS Horizon 31.0.8 and versions earlier than 32.0.2 on multiple platforms is vulnerable to elevation of privilege. The solution is to upgrade to Meridian 2023.1.6, 2022.1.19, 2021.1.30, 2020.1.38 or Horizon 32.0.2 or newer. Meridian and Horizon installation instructions state that they are intended for installation within an organization's private networks and should not be directly accessible from the Internet. OpenNMS thanks Erik Wynter for reporting this issue.

Published 2023-08-14 · CVE record · OSV

Products: The OpenNMS Group Horizon, The OpenNMS Group Meridian

Fixed upstream

EcosystemPackageFixed in
Mavenorg.opennms:opennms-webapp-rest32.0.2