Patchwire CVEs, their patch status, and feeds to follow them

CVE-2023-0666

Fixed in a distro release EPSS 2%CVSS 6.5

Due to failure in validating the length provided by an attacker-crafted RTPS packet, Wireshark version 4.0.5 and prior, by default, is susceptible to a heap-based buffer overflow, and possibly code execution in the context of the process running Wireshark.

Published 2023-06-07 · CVE record · OSV

Products: Wireshark Foundation Wireshark

Distro releases

ReleasePackageFixed in
AlmaLinux:8wireshark1:2.6.2-17.el8
AlmaLinux:8wireshark-cli1:2.6.2-17.el8
AlmaLinux:8wireshark-devel1:2.6.2-17.el8
AlmaLinux:9wireshark1:3.4.10-6.el9
AlmaLinux:9wireshark-cli1:3.4.10-6.el9
AlmaLinux:9wireshark-devel1:3.4.10-6.el9
Debian:11wireshark3.4.16-0+deb11u1
Debian:12wireshark4.0.6-1~deb12u1
Debian:13wireshark4.0.6-1
Debian:14wireshark4.0.6-1
Red Hat:enterprise_linux:8wireshark1:2.6.2-17.el8
Red Hat:enterprise_linux:8wireshark-cli1:2.6.2-17.el8
Red Hat:enterprise_linux:8wireshark-cli-debuginfo1:2.6.2-17.el8
Red Hat:enterprise_linux:8wireshark-debuginfo1:2.6.2-17.el8
Red Hat:enterprise_linux:8wireshark-debugsource1:2.6.2-17.el8
Red Hat:enterprise_linux:8wireshark-devel1:2.6.2-17.el8
Red Hat:enterprise_linux:9wireshark1:3.4.10-6.el9
Red Hat:enterprise_linux:9wireshark-cli1:3.4.10-6.el9
Red Hat:enterprise_linux:9wireshark-cli-debuginfo1:3.4.10-6.el9
Red Hat:enterprise_linux:9wireshark-debuginfo1:3.4.10-6.el9
Red Hat:enterprise_linux:9wireshark-debugsource1:3.4.10-6.el9
Red Hat:enterprise_linux:9wireshark-devel1:3.4.10-6.el9
Rocky Linux:8wireshark1:2.6.2-17.el8
SUSE:Linux Enterprise Module for Basesystem 15 SP6wireshark4.2.6-150600.18.6.1
SUSE:Linux Enterprise Module for Desktop Applications 15 SP6wireshark4.2.6-150600.18.6.1
Ubuntu:Pro:14.04:LTSwiresharkno fix
Ubuntu:Pro:16.04:LTSwiresharkno fix
Ubuntu:Pro:18.04:LTSwiresharkno fix
Ubuntu:Pro:20.04:LTSwiresharkno fix
Ubuntu:Pro:22.04:LTSwiresharkno fix
openSUSE:Leap 15.6wireshark4.2.6-150600.18.6.1
openSUSE:Tumbleweedwireshark4.0.6-1.1