Patchwire CVEs, their patch status, and feeds to follow them

CVE-2022-4967

Fixed in a distro release EPSS <1%CVSS 7.7

strongSwan versions 5.9.2 through 5.9.5 are affected by authorization bypass through improper validation of certificate with host mismatch (CWE-297). When certificates are used to authenticate clients in TLS-based EAP methods, the IKE or EAP identity supplied by a client is not enforced to be contained in the client's certificate. So clients can authenticate with any trusted certificate and claim an arbitrary IKE/EAP identity as their own. This is problematic if the identity is used to make policy decisions. A fix was released in strongSwan version 5.9.6 in August 2022 (e4b4aabc4996fc61c37deab7858d07bc4d220136).

Published 2024-05-13 · CVE record · OSV

Products: strongswan

Distro releases

ReleasePackageFixed in
Debian 12strongswan5.9.6-1
Debian 13strongswan5.9.6-1
Debian 14strongswan5.9.6-1
Ubuntu 22.04 LTSstrongswan5.9.5-2ubuntu2.3