CVE-2022-42905
Fixed in a distro release EPSS 2%CVSS 9.1
In wolfSSL before 5.5.2, if callback functions are enabled (via the WOLFSSL_CALLBACKS flag), then a malicious TLS 1.3 client or network attacker can trigger a buffer over-read on the heap of 5 bytes. (WOLFSSL_CALLBACKS is only intended for debugging.)
Products: wolfssl
Distro releases
| Release | Package | Fixed in |
|---|---|---|
| Debian 12 | wolfssl | 5.5.3-1 |
| Debian 13 | wolfssl | 5.5.3-1 |
| Ubuntu 16.04 LTS | wolfssl | no fix |
| Ubuntu 18.04 LTS | wolfssl | no fix |
| Ubuntu 20.04 LTS | wolfssl | no fix |
| Ubuntu 22.04 LTS | wolfssl | no fix |
| Ubuntu 24.04 LTS | wolfssl | no fix |
| Ubuntu 25.10 | wolfssl | no fix |
| Ubuntu 26.04 LTS | wolfssl | no fix |
| Ubuntu 26.10 | wolfssl | no fix |