CVE-2022-41325
Fixed in a distro release EPSS <1%CVSS 7.8
An integer overflow in the VNC module in VideoLAN VLC Media Player through 3.0.17.4 allows attackers, by tricking a user into opening a crafted playlist or connecting to a rogue VNC server, to crash VLC or execute code under some conditions.
Products: videolan vlc_media_player, debian_linux
Distro releases
| Release | Package | Fixed in |
|---|---|---|
| Debian 10 | vlc | 3.0.17.4-0+deb10u2 |
| Debian 11 | vlc | 3.0.18-0+deb11u1 |
| Debian 12 | vlc | 3.0.18-1 |
| Debian 13 | vlc | 3.0.18-1 |
| Debian 14 | vlc | 3.0.18-1 |
| SUSE Package Hub 15 SP3 | vlc | 3.0.18-bp153.2.6.1 |
| SUSE Package Hub 15 SP4 | vlc | 3.0.18-bp154.2.3.1 |
| SUSE Package Hub 15 SP5 | vlc | 3.0.20-bp155.2.3.1 |
| Ubuntu Pro 16.04 LTS | vlc | 2.2.2-5ubuntu0.16.04.5+esm2 |
| Ubuntu Pro 18.04 LTS | vlc | 3.0.8-0ubuntu18.04.1+esm1 |
| Ubuntu Pro 20.04 LTS | vlc | 3.0.9.2-1ubuntu0.1~esm1 |
| Ubuntu Pro 22.04 LTS | vlc | 3.0.16-1ubuntu0.1~esm1 |
| openSUSE Leap 15.3 | vlc | 3.0.18-bp153.2.6.1 |
| openSUSE Leap 15.4 | vlc | 3.0.18-bp154.2.3.1 |
| openSUSE Leap 15.5 | vlc | 3.0.20-bp155.2.3.1 |
| openSUSE Tumbleweed | vlc | 3.0.18-4.1 |