CVE-2022-39334
Fixed in a distro release EPSS <1%CVSS 3.9
Nextcloud also ships a CLI utility called nextcloudcmd which is sometimes used for automated scripting and headless servers. Versions of nextcloudcmd prior to 3.6.1 would incorrectly trust invalid TLS certificates, which may enable a Man-in-the-middle attack that exposes sensitive data or credentials to a network attacker. This affects the CLI only. It does not affect the standard GUI desktop Nextcloud clients, and it does not affect the Nextcloud server.
Products: nextcloud security-advisories
Distro releases
| Release | Package | Fixed in |
|---|---|---|
| Debian 11 | nextcloud-desktop | 3.1.1-2+deb11u2 |
| Debian 12 | nextcloud-desktop | 3.6.1-1 |
| Debian 13 | nextcloud-desktop | 3.6.1-1 |
| Debian 14 | nextcloud-desktop | 3.6.1-1 |
| SUSE Package Hub 15 SP4 | nextcloud-desktop | 3.8.0-bp154.2.3.1 |
| SUSE Package Hub 15 SP5 | nextcloud-desktop | 3.8.0-bp155.2.3.1 |
| Ubuntu 20.04 LTS | nextcloud-desktop | no fix |
| Ubuntu 22.04 LTS | nextcloud-desktop | no fix |
| Ubuntu 24.04 LTS | nextcloud-desktop | no fix |
| Ubuntu 25.10 | nextcloud-desktop | no fix |
| Ubuntu 26.04 LTS | nextcloud-desktop | no fix |
| Ubuntu 26.10 | nextcloud-desktop | no fix |
| openSUSE Leap 15.4 | nextcloud-desktop | 3.8.0-bp154.2.3.1 |
| openSUSE Leap 15.5 | nextcloud-desktop | 3.8.0-bp155.2.3.1 |