CVE-2022-3276
Fixed in a distro release EPSS 2%CVSS 8.4
Command injection is possible in the puppetlabs-mysql module prior to version 13.0.0. A malicious actor is able to exploit this vulnerability only if they are able to provide unsanitized input to the module. This condition is rare in most deployments of Puppet and Puppet Enterprise.
Products: puppetlabs/mysql
Distro releases
| Release | Package | Fixed in |
|---|---|---|
| Debian 12 | puppet-module-puppetlabs-mysql | no fix |
| Debian 13 | puppet-module-puppetlabs-mysql | 15.0.0-1 |
| Debian 14 | puppet-module-puppetlabs-mysql | 15.0.0-1 |
| Red Hat openstack 13 | puppet-mysql | 0:5.2.2-0.20180216012143.a5497b2.el7ost |
| Red Hat openstack 16.1 | puppet-mysql | 0:10.4.1-2.20221019195006.95f9b98.el8ost |
| Red Hat openstack 16.2 | puppet-mysql | 0:10.4.1-2.20221019195006.95f9b98.el8ost |
| Red Hat openstack 17.0 | puppet-mysql | 0:10.6.1-0.20220614215045.937d044.el9ost |
| Ubuntu 16.04 LTS | puppet-module-puppetlabs-mysql | no fix |
| Ubuntu 18.04 LTS | puppet-module-puppetlabs-mysql | no fix |
| Ubuntu 20.04 LTS | puppet-module-puppetlabs-mysql | no fix |
| Ubuntu 22.04 LTS | puppet-module-puppetlabs-mysql | no fix |
| Ubuntu 24.04 LTS | puppet-module-puppetlabs-mysql | no fix |
| Ubuntu 25.10 | puppet-module-puppetlabs-mysql | no fix |
| Ubuntu 26.04 LTS | puppet-module-puppetlabs-mysql | no fix |
| Ubuntu 26.10 | puppet-module-puppetlabs-mysql | no fix |