CVE-2022-3275
Fixed in a distro release EPSS 2%CVSS 8.4
Command injection is possible in the puppetlabs-apt module prior to version 9.0.0. A malicious actor is able to exploit this vulnerability only if they are able to provide unsanitized input to the module. This condition is rare in most deployments of Puppet and Puppet Enterprise.
Products: puppetlabs/apt
Distro releases
| Release | Package | Fixed in |
|---|---|---|
| Debian 12 | puppet-module-puppetlabs-apt | 9.0.1-1 |
| Debian 13 | puppet-module-puppetlabs-apt | 9.0.1-1 |
| Debian 14 | puppet-module-puppetlabs-apt | 9.0.1-1 |
| Ubuntu 16.04 LTS | puppet-module-puppetlabs-apt | no fix |
| Ubuntu 18.04 LTS | puppet-module-puppetlabs-apt | no fix |
| Ubuntu 20.04 LTS | puppet-module-puppetlabs-apt | no fix |
| Ubuntu 22.04 LTS | puppet-module-puppetlabs-apt | no fix |