CVE-2022-31777
Fixed upstream EPSS 2%CVSS 5.4
A stored cross-site scripting (XSS) vulnerability in Apache Spark 3.2.1 and earlier, and 3.3.0, allows remote attackers to execute arbitrary JavaScript in the web browser of a user, by including a malicious payload into the logs which would be returned in logs rendered in the UI.
Products: Apache Software Foundation Apache Spark
Fixed upstream
| Ecosystem | Package | Fixed in |
|---|---|---|
| Maven | org.apache.spark:spark-core_2.10 | no fix |
| Maven | org.apache.spark:spark-core_2.11 | no fix |
| Maven | org.apache.spark:spark-core_2.12 | 3.2.2 |
| Maven | org.apache.spark:spark-core_2.12 | 3.3.1 |
| Maven | org.apache.spark:spark-core_2.13 | 3.2.2 |
| Maven | org.apache.spark:spark-core_2.13 | 3.3.1 |
| Maven | org.apache.spark:spark-core_2.9.3 | no fix |
| PyPI | pyspark | 3.2.2 |
| PyPI | pyspark | 3.3.1 |