CVE-2022-31249
Fixed upstream EPSS 4%CVSS 7.5
A Improper Neutralization of Special Elements used in an OS Command ('OS Command Injection') vulnerability in wrangler of SUSE Rancher allows remote attackers to inject commands in the underlying host via crafted commands passed to Wrangler. This issue affects: SUSE Rancher wrangler version 0.7.3 and prior versions; wrangler version 0.8.4 and prior versions; wrangler version 1.0.0 and prior versions.
Products: SUSE Rancher
Fixed upstream
| Ecosystem | Package | Fixed in |
|---|---|---|
| Go | github.com/rancher/wrangler | 0.7.4-security1 |
| Go | github.com/rancher/wrangler | 0.8.5-security1 |
| Go | github.com/rancher/wrangler | 1.0.1 |
| Go | github.com/rancher/wrangler | 0.8.11 |