Patchwire CVEs, their patch status, and feeds to follow them

CVE-2022-29248

Fixed in a distro release EPSS 1%CVSS 8.0

Guzzle is a PHP HTTP client. Guzzle prior to versions 6.5.6 and 7.4.3 contains a vulnerability with the cookie middleware. The vulnerability is that it is not checked if the cookie domain equals the domain of the server which sets the cookie via the Set-Cookie header, allowing a malicious server to set cookies for unrelated domains. The cookie middleware is disabled by default, so most library consumers will not be affected by this issue. Only those who manually add the cookie middleware to the handler stack or construct the client with ['cookies' => true] are affected. Moreover, those who do not use the same Guzzle client to call multiple domains and have disabled redirect forwarding are not affected by this vulnerability. Guzzle versions 6.5.6 and 7.4.3 contain a patch for this issue. As a workaround, turn off the cookie middleware.

Published 2022-05-25 · CVE record · OSV

Products: guzzle

Fixed upstream

EcosystemPackageFixed in
Packagistdrupal/core9.2.20
Packagistdrupal/core9.3.14
Packagistguzzlehttp/guzzle6.5.6
Packagistguzzlehttp/guzzle7.4.3

Distro releases

ReleasePackageFixed in
Arch Linuxmediawiki1.38.3-1
Debian 11mediawiki1:1.35.8-1~deb11u1
Debian 12guzzle7.4.4-1
Debian 12mediawiki1:1.35.7-1
Debian 13guzzle7.4.4-1
Debian 13mediawiki1:1.35.7-1
Debian 14guzzle7.4.4-1
Debian 14mediawiki1:1.35.7-1
Ubuntu 24.04 LTSguzzleno fix
Ubuntu 25.10guzzleno fix
Ubuntu 26.04 LTSguzzleno fix
Ubuntu 26.10guzzleno fix