Patchwire CVEs, their patch status, and feeds to follow them

CVE-2022-29208

Fixed upstream EPSS <1%CVSS 7.1

TensorFlow is an open source platform for machine learning. Prior to versions 2.9.0, 2.8.1, 2.7.2, and 2.6.4, the implementation of `tf.raw_ops.EditDistance` has incomplete validation. Users can pass negative values to cause a segmentation fault based denial of service. In multiple places throughout the code, one may compute an index for a write operation. However, the existing validation only checks against the upper bound of the array. Hence, it is possible to write before the array by massaging the input to generate negative values for `loc`. Versions 2.9.0, 2.8.1, 2.7.2, and 2.6.4 contain a patch for this issue.

Published 2022-05-20 · CVE record · OSV

Products: tensorflow

Fixed upstream

EcosystemPackageFixed in
PyPItensorflow2.6.4
PyPItensorflow2.7.2
PyPItensorflow2.8.1
PyPItensorflow-cpu2.6.4
PyPItensorflow-cpu2.7.2
PyPItensorflow-cpu2.8.1
PyPItensorflow-gpu2.6.4
PyPItensorflow-gpu2.7.2
PyPItensorflow-gpu2.8.1