CVE-2022-29198
Fixed upstream EPSS <1%CVSS 5.5
TensorFlow is an open source platform for machine learning. Prior to versions 2.9.0, 2.8.1, 2.7.2, and 2.6.4, the implementation of `tf.raw_ops.SparseTensorToCSRSparseMatrix` does not fully validate the input arguments. This results in a `CHECK`-failure which can be used to trigger a denial of service attack. The code assumes `dense_shape` is a vector and `indices` is a matrix (as part of requirements for sparse tensors) but there is no validation for this. Versions 2.9.0, 2.8.1, 2.7.2, and 2.6.4 contain a patch for this issue.
Products: tensorflow
Fixed upstream
| Ecosystem | Package | Fixed in |
|---|---|---|
| PyPI | tensorflow | 2.6.4 |
| PyPI | tensorflow | 2.7.2 |
| PyPI | tensorflow | 2.8.1 |
| PyPI | tensorflow-cpu | 2.6.4 |
| PyPI | tensorflow-cpu | 2.7.2 |
| PyPI | tensorflow-cpu | 2.8.1 |
| PyPI | tensorflow-gpu | 2.6.4 |
| PyPI | tensorflow-gpu | 2.7.2 |
| PyPI | tensorflow-gpu | 2.8.1 |