CVE-2022-28366
Fixed in a distro release EPSS 2%
Certain Neko-related HTML parsers allow a denial of service via crafted Processing Instruction (PI) input that causes excessive heap memory consumption. In particular, this issue exists in HtmlUnit-Neko through 2.26, and is fixed in 2.27. This issue also exists in CyberNeko HTML through 1.9.22 (also affecting OWASP AntiSamy before 1.6.6), but 1.9.22 is the last version of CyberNeko HTML. NOTE: this may be related to CVE-2022-24839.
Products: cyberneko_html_project cyberneko_html, htmlunit, antisamy_project antisamy
Fixed upstream
| Ecosystem | Package | Fixed in |
|---|---|---|
| Maven | net.sourceforge.htmlunit:neko-htmlunit | 2.27 |
Distro releases
| Release | Package | Fixed in |
|---|---|---|
| Debian 12 | libowasp-antisamy-java | no fix |
| Debian 13 | libowasp-antisamy-java | 1.7.4-1 |
| Debian 14 | libowasp-antisamy-java | 1.7.4-1 |
| Ubuntu 16.04 LTS | libowasp-antisamy-java | no fix |
| Ubuntu 18.04 LTS | libowasp-antisamy-java | no fix |
| Ubuntu 20.04 LTS | libowasp-antisamy-java | no fix |
| Ubuntu 22.04 LTS | libowasp-antisamy-java | no fix |
| Ubuntu 24.04 LTS | libowasp-antisamy-java | no fix |
| Ubuntu 25.10 | libowasp-antisamy-java | no fix |
| Ubuntu 26.04 LTS | libowasp-antisamy-java | no fix |
| Ubuntu 26.10 | libowasp-antisamy-java | no fix |