CVE-2022-25927
Fixed in a distro release EPSS 2%CVSS 5.3
Versions of the package ua-parser-js from 0.7.30 and before 0.7.33, from 0.8.1 and before 1.0.33 are vulnerable to Regular Expression Denial of Service (ReDoS) via the trim() function.
Products: ua-parser-js_project ua-parser-js
Fixed upstream
| Ecosystem | Package | Fixed in |
|---|---|---|
| npm | ua-parser-js | 0.7.33 |
| npm | ua-parser-js | 1.0.33 |
Distro releases
| Release | Package | Fixed in |
|---|---|---|
| Debian 12 | node-ua-parser-js | 0.8.1+ds+~0.7.36-3 |
| Debian 13 | node-ua-parser-js | 0.8.1+ds+~0.7.36-3 |
| Debian 14 | node-ua-parser-js | 0.8.1+ds+~0.7.36-3 |
| Ubuntu 18.04 LTS | node-ua-parser-js | no fix |
| Ubuntu 20.04 LTS | node-ua-parser-js | no fix |
| Ubuntu 22.04 LTS | node-ua-parser-js | no fix |
| Ubuntu 24.04 LTS | node-ua-parser-js | no fix |
| Ubuntu 25.10 | node-ua-parser-js | no fix |
| Ubuntu 26.04 LTS | node-ua-parser-js | no fix |
| Ubuntu 26.10 | node-ua-parser-js | no fix |