CVE-2022-24758
Fixed in a distro release EPSS 1%CVSS 7.5
The Jupyter notebook is a web-based notebook environment for interactive computing. Prior to version 6.4.9, unauthorized actors can access sensitive information from server logs. Anytime a 5xx error is triggered, the auth cookie and other header values are recorded in Jupyter server logs by default. Considering these logs do not require root access, an attacker can monitor these logs, steal sensitive auth/cookie information, and gain access to the Jupyter server. Jupyter notebook version 6.4.x contains a patch for this issue. There are currently no known workarounds.
Products: jupyter notebook
Fixed upstream
| Ecosystem | Package | Fixed in |
|---|---|---|
| PyPI | notebook | 6.4.10 |
Distro releases
| Release | Package | Fixed in |
|---|---|---|
| Debian 12 | jupyter-notebook | 6.4.12-1 |
| Debian 13 | jupyter-notebook | 6.4.12-1 |
| Debian 14 | jupyter-notebook | 6.4.12-1 |
| Ubuntu 18.04 LTS | jupyter-notebook | 5.2.2-1ubuntu0.1 |
| Ubuntu 20.04 LTS | jupyter-notebook | 6.0.3-2ubuntu0.1 |
| Ubuntu 22.04 LTS | jupyter-notebook | 6.4.8-1ubuntu0.1 |