CVE-2022-24757
Fixed in a distro release EPSS 1%CVSS 7.5
The Jupyter Server provides the backend (i.e. the core services, APIs, and REST endpoints) for Jupyter web applications. Prior to version 1.15.4, unauthorized actors can access sensitive information from server logs. Anytime a 5xx error is triggered, the auth cookie and other header values are recorded in Jupyter Server logs by default. Considering these logs do not require root access, an attacker can monitor these logs, steal sensitive auth/cookie information, and gain access to the Jupyter server. Jupyter Server version 1.15.4 contains a patch for this issue. There are currently no known workarounds.
Products: jupyter-server jupyter_server
Fixed upstream
| Ecosystem | Package | Fixed in |
|---|---|---|
| PyPI | jupyter-server | 1.15.4 |
| PyPI | jupyter-server | a5683aca0b0e412672ac6218d09f74d44ca0de5a |
Distro releases
| Release | Package | Fixed in |
|---|---|---|
| Debian 12 | jupyter-server | 1.16.0-1 |
| Debian 13 | jupyter-server | 1.16.0-1 |
| Debian 14 | jupyter-server | 1.16.0-1 |
| Ubuntu 22.04 LTS | jupyter-server | no fix |