CVE-2022-23647
Fixed in a distro release EPSS 1%CVSS 7.5
Prism is a syntax highlighting library. Starting with version 1.14.0 and prior to version 1.27.0, Prism's command line plugin can be used by attackers to achieve a cross-site scripting attack. The command line plugin did not properly escape its output, leading to the input text being inserted into the DOM as HTML code. Server-side usage of Prism is not impacted. Websites that do not use the Command Line plugin are also not impacted. This bug has been fixed in v1.27.0. As a workaround, do not use the command line plugin on untrusted inputs, or sanitize all code blocks (remove all HTML code text) from all code blocks that use the command line plugin.
Products: PrismJS prism
Fixed upstream
| Ecosystem | Package | Fixed in |
|---|---|---|
| npm | prismjs | 1.27.0 |
Distro releases
| Release | Package | Fixed in |
|---|---|---|
| Debian 12 | node-prismjs | 1.27.0+dfsg+~1.26.0-1 |
| Debian 13 | node-prismjs | 1.27.0+dfsg+~1.26.0-1 |
| Debian 14 | node-prismjs | 1.27.0+dfsg+~1.26.0-1 |
| Ubuntu 20.04 LTS | node-prismjs | no fix |
| Ubuntu 22.04 LTS | node-prismjs | no fix |