Patchwire CVEs, their patch status, and feeds to follow them

CVE-2022-21222

Fixed in a distro release EPSS 2%CVSS 5.3

The package css-what before 2.1.3 are vulnerable to Regular Expression Denial of Service (ReDoS) due to the usage of insecure regular expression in the re_attr variable of index.js. The exploitation of this vulnerability could be triggered via the parse function.

Published 2022-09-30 · CVE record · OSV

Products: css-what_project css-what

Fixed upstream

EcosystemPackageFixed in
npmcss-what2.1.3

Distro releases

ReleasePackageFixed in
Debian 10node-css-what2.1.0-1+deb10u1
Debian 12node-css-what5.0.1-1
Debian 13node-css-what5.0.1-1
Debian 14node-css-what5.0.1-1
Ubuntu 18.04 LTSnode-css-what2.1.0-1+deb10u1build0.18.04.1
Ubuntu 24.04 LTSnode-css-whatno fix
Ubuntu 25.10node-css-whatno fix
Ubuntu 26.04 LTSnode-css-whatno fix
Ubuntu 26.10node-css-whatno fix
Ubuntu Pro 16.04 LTSnode-css-what2.1.0-1ubuntu0.16.04.1~esm1
Ubuntu Pro 20.04 LTSnode-css-what3.2.1-1ubuntu0.1~esm1