CVE-2021-43854
Fixed in a distro release EPSS 3%CVSS 7.5
NLTK (Natural Language Toolkit) is a suite of open source Python modules, data sets, and tutorials supporting research and development in Natural Language Processing. Versions prior to 3.6.5 are vulnerable to regular expression denial of service (ReDoS) attacks. The vulnerability is present in PunktSentenceTokenizer, sent_tokenize and word_tokenize. Any users of this class, or these two functions, are vulnerable to the ReDoS attack. In short, a specifically crafted long input to any of these vulnerable functions will cause them to take a significant amount of execution time. If your program relies on any of the vulnerable functions for tokenizing unpredictable user input, then we would strongly recommend upgrading to a version of NLTK without the vulnerability. For users unable to upgrade the execution time can be bounded by limiting the maximum length of an input to any of the vulnerable functions. Our recommendation is to implement such a limit.
Products: nltk
Fixed upstream
| Ecosystem | Package | Fixed in |
|---|---|---|
| PyPI | nltk | 3.6.6 |
| PyPI | nltk | 1405aad979c6b8080dbbc8e0858f89b2e3690341 |
| PyPI | nltk | 3.6.5 |
Distro releases
| Release | Package | Fixed in |
|---|---|---|
| Debian 12 | nltk | 3.6.7-1 |
| Debian 13 | nltk | 3.6.7-1 |
| Debian 14 | nltk | 3.6.7-1 |
| Ubuntu Pro 14.04 LTS | nltk | 2.0~b9-0ubuntu4.1~esm4 |
| Ubuntu Pro 16.04 LTS | nltk | 3.1-1ubuntu0.1+esm2 |
| Ubuntu Pro 18.04 LTS | nltk | 3.2.5-1ubuntu0.1+esm2 |
| Ubuntu Pro 20.04 LTS | nltk | 3.4.5-2ubuntu0.1~esm2 |