CVE-2021-43803
Fixed in a distro release EPSS 47%CVSS 7.5
Next.js is a React framework. In versions of Next.js prior to 12.0.5 or 11.1.3, invalid or malformed URLs could lead to a server crash. In order to be affected by this issue, the deployment must use Next.js versions above 11.1.0 and below 12.0.5, Node.js above 15.0.0, and next start or a custom server. Deployments on Vercel are not affected, along with similar environments where invalid requests are filtered before reaching Next.js. Versions 12.0.5 and 11.1.3 contain patches for this issue.
Products: vercel next.js
Fixed upstream
| Ecosystem | Package | Fixed in |
|---|---|---|
| npm | next | 12.0.5 |
| npm | next | 11.1.3 |
Distro releases
| Release | Package | Fixed in |
|---|---|---|
| Alpine 3.15 | nodejs | 0 |
| Alpine 3.16 | nodejs | 0 |
| Alpine 3.17 | nodejs | 0 |
| Alpine 3.18 | nodejs | 0 |
| Alpine 3.19 | nodejs | 0 |
| Alpine 3.20 | nodejs | 0 |
| Alpine 3.21 | nodejs | 0 |
| Alpine 3.22 | nodejs | 0 |
| Alpine 3.23 | nodejs | 0 |
| Alpine 3.24 | nodejs | 0 |