Patchwire CVEs, their patch status, and feeds to follow them

CVE-2021-38153

Fixed in a distro release EPSS 6%

Some components in Apache Kafka use `Arrays.equals` to validate a password or key, which is vulnerable to timing attacks that make brute force attacks for such credentials more likely to be successful. Users should upgrade to 2.8.1 or higher, or 3.0.0 or higher where this vulnerability has been fixed. The affected versions include Apache Kafka 2.0.0, 2.0.1, 2.1.0, 2.1.1, 2.2.0, 2.2.1, 2.2.2, 2.3.0, 2.3.1, 2.4.0, 2.4.1, 2.5.0, 2.5.1, 2.6.0, 2.6.1, 2.6.2, 2.7.0, 2.7.1, and 2.8.0.

Published 2021-09-22 · CVE record · OSV

Products: Apache Software Foundation Apache Kafka

Fixed upstream

EcosystemPackageFixed in
Mavenorg.apache.kafka:kafka-clients2.6.3
Mavenorg.apache.kafka:kafka-clients2.7.2
Mavenorg.apache.kafka:kafka-clients2.8.1
Mavenorg.apache.kafka:kafka_2.11no fix
Mavenorg.apache.kafka:kafka_2.122.6.3
Mavenorg.apache.kafka:kafka_2.122.7.2
Mavenorg.apache.kafka:kafka_2.122.8.1
Mavenorg.apache.kafka:kafka_2.132.6.3
Mavenorg.apache.kafka:kafka_2.132.7.2
Mavenorg.apache.kafka:kafka_2.132.8.1

Distro releases

ReleasePackageFixed in
Chainguardapache-nifi1.26.0-r2
Chainguardapache-nifi2.6.0-r2
Chainguardapache-nifi-compat2.6.0-r2
Chainguardapache-nifi-toolkit2.6.0-r2
Chainguardhive4.0.1-r1
Chainguardhive-compat4.0.1-r1
Ubuntu:Pro:18.04:LTSkafkano fix
Wolfiapache-nifi2.6.0-r2
Wolfiapache-nifi-compat2.6.0-r2
Wolfiapache-nifi-toolkit2.6.0-r2