CVE-2021-34337
Fixed in a distro release EPSS <1%CVSS 6.3
An issue was discovered in Mailman Core before 3.3.5. An attacker with access to the REST API could use timing attacks to determine the value of the configured REST API password and then make arbitrary REST API calls. The REST API is bound to localhost by default, limiting the ability for attackers to exploit this, but can optionally be made to listen on other interfaces.
Products: gnu mailman
Fixed upstream
| Ecosystem | Package | Fixed in |
|---|---|---|
| PyPI | mailman | 3.3.5 |
| PyPI | mailman | e4a39488c4510fcad8851217f10e7337a196bb51 |
Distro releases
| Release | Package | Fixed in |
|---|---|---|
| Debian 12 | mailman3 | 3.3.7-1 |
| Debian 13 | mailman3 | 3.3.7-1 |
| Debian 14 | mailman3 | 3.3.7-1 |
| Ubuntu 18.04 LTS | mailman3 | no fix |
| Ubuntu 20.04 LTS | mailman3 | no fix |
| openSUSE Tumbleweed | mailman3 | 3.3.5-2.1 |
| openSUSE Tumbleweed | python3-mailman | 3.3.5-1.1 |