CVE-2021-33036
Fixed upstream EPSS 4%
In Apache Hadoop 2.2.0 to 2.10.1, 3.0.0-alpha1 to 3.1.4, 3.2.0 to 3.2.2, and 3.3.0 to 3.3.1, a user who can escalate to yarn user can possibly run arbitrary commands as root user. Users should upgrade to Apache Hadoop 2.10.2, 3.2.3, 3.3.2 or higher.
Products: Apache Software Foundation Apache Hadoop
Fixed upstream
| Ecosystem | Package | Fixed in |
|---|---|---|
| Maven | org.apache.hadoop:hadoop-yarn-server-common | 2.10.2 |
| Maven | org.apache.hadoop:hadoop-yarn-server-common | 3.2.3 |
| Maven | org.apache.hadoop:hadoop-yarn-server-common | 3.3.2 |