CVE-2021-32761
Fixed in a distro release EPSS 30%CVSS 7.5
Redis is an in-memory database that persists on disk. A vulnerability involving out-of-bounds read and integer overflow to buffer overflow exists starting with version 2.2 and prior to versions 5.0.13, 6.0.15, and 6.2.5. On 32-bit systems, Redis `*BIT*` command are vulnerable to integer overflow that can potentially be exploited to corrupt the heap, leak arbitrary heap contents or trigger remote code execution. The vulnerability involves changing the default `proto-max-bulk-len` configuration parameter to a very large value and constructing specially crafted commands bit commands. This problem only affects Redis on 32-bit platforms, or compiled as a 32-bit binary. Redis versions 5.0.`3m 6.0.15, and 6.2.5 contain patches for this issue. An additional workaround to mitigate the problem without patching the `redis-server` executable is to prevent users from modifying the `proto-max-bulk-len` configuration parameter. This can be done using ACL to restrict unprivileged users from using the CONFIG SET command.
Products: Redis
Distro releases
| Release | Package | Fixed in |
|---|---|---|
| Alpine 3.11 | redis | 5.0.13-r0 |
| Alpine 3.12 | redis | 5.0.13-r0 |
| Alpine 3.13 | redis | 6.0.13-r0 |
| Alpine 3.14 | redis | 6.2.5-r0 |
| Alpine 3.15 | redis | 6.2.5-r0 |
| Alpine 3.16 | redis | 6.2.5-r0 |
| Alpine 3.17 | redis | 6.2.5-r0 |
| Alpine 3.18 | redis | 6.2.5-r0 |
| Alpine 3.19 | redis | 6.2.5-r0 |
| Debian 12 | redis | 5:6.0.15-1 |
| Debian 13 | redis | 5:6.0.15-1 |
| Debian 14 | redis | 5:6.0.15-1 |
| Debian 9 | redis | 3:3.2.6-3+deb9u5 |
| Debian 9 | redis | 3:3.2.6-3+deb9u6 |
| Ubuntu Pro 14.04 LTS | redis | 2:2.8.4-2ubuntu0.2+esm2 |
| Ubuntu Pro 16.04 LTS | redis | 2:3.0.6-1ubuntu0.4+esm1 |
| Ubuntu Pro 18.04 LTS | redis | 5:4.0.9-1ubuntu0.2+esm3 |
| Ubuntu Pro 20.04 LTS | redis | 5:5.0.7-2ubuntu0.1+esm1 |
| openSUSE Tumbleweed | redis | 6.2.5-1.2 |