CVE-2021-32723
Fixed upstream EPSS 1%CVSS 7.4
Prism is a syntax highlighting library. Some languages before 1.24.0 are vulnerable to Regular Expression Denial of Service (ReDoS). When Prism is used to highlight untrusted (user-given) text, an attacker can craft a string that will take a very very long time to highlight. This problem has been fixed in Prism v1.24. As a workaround, do not use ASCIIDoc or ERB to highlight untrusted text. Other languages are not affected and can be used to highlight untrusted text.
Products: PrismJS prism
Fixed upstream
| Ecosystem | Package | Fixed in |
|---|---|---|
| npm | prismjs | 1.24.0 |
Distro releases
| Release | Package | Fixed in |
|---|---|---|
| Ubuntu 20.04 LTS | node-prismjs | no fix |
| Ubuntu 22.04 LTS | node-prismjs | no fix |
| Ubuntu 24.04 LTS | node-prismjs | no fix |
| Ubuntu 25.10 | node-prismjs | no fix |
| Ubuntu 26.04 LTS | node-prismjs | no fix |
| Ubuntu 26.10 | node-prismjs | no fix |