CVE-2021-32678
Fixed in a distro release EPSS 1%CVSS 3.7
Nextcloud Server is a Nextcloud package that handles data storage. In versions prior to 19.0.13, 20.0.11, and 21.0.3, ratelimits are not applied to OCS API responses. This affects any OCS API controller (`OCSController`) using the `@BruteForceProtection` annotation. Risk depends on the installed applications on the Nextcloud Server, but could range from bypassing authentication ratelimits or spamming other Nextcloud users. The vulnerability is patched in versions 19.0.13, 20.0.11, and 21.0.3. No workarounds aside from upgrading are known to exist.
Products: nextcloud security-advisories
Distro releases
| Release | Package | Fixed in |
|---|---|---|
| Arch Linux | nextcloud | 21.0.3-1 |
| SUSE Package Hub 12 | nextcloud | 20.0.11-bp153.2.3.1 |
| SUSE Package Hub 15 SP1 | nextcloud | 20.0.11-bp153.2.3.1 |
| SUSE Package Hub 15 SP2 | nextcloud | 20.0.11-bp153.2.3.1 |
| SUSE Package Hub 15 SP3 | nextcloud | 20.0.11-bp153.2.3.1 |
| openSUSE Leap 15.2 | nextcloud | 20.0.11-bp153.2.3.1 |
| openSUSE Leap 15.3 | nextcloud | 20.0.11-bp153.2.3.1 |